[image: image1.jpg]Vodafone Mobile Connect
VPN Guide




	VPN End to End – 
Checkpoint FW-1/VPN-1 NGX VPN
	
	[image: image30.jpg]o

vodafone







VPN End to End - Checkpoint FW-1/VPN-1 NGX - Appendix
Appendix A: Checkpoint FW-1/VPN-1 NGX VPN gateway
Technical Notes for use with Vodafone Mobile Connect services
Date: 30 November 2006
Revision No: 3.0
[image: image31.jpg]o

vodafone




© VODAFONE GROUP 2006

Scope

This document presents results of installation, configuration, and operations testing of VPN components with the Vodafone Mobile Connect service. The document is not intended to be a tutorial on VPN concepts nor does it supersede or replace the vendor’s documentation. The reader is referred to the VPN vendor for definitive guidance on the proper and recommended use of their product. While Vodafone Group has taken care to ensure that the information contained herein is accurate, no responsibility can be accepted for errors, omissions, or inaccuracies.
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1 Executive summary

This Appendix is in addition to the detailed document for Checkpoint FW-1/VPN-1 NGX VPN gateway and describes the setup and update process for a remote access VPN for GPRS/UMTS usage in a detailed way with example screen shots taken from the initial processes.

Furthermore logging and additional functionality is described in the appropriate chapters.

2 VPN gateway Installation and Configuration

The following description is intended for network administrators who are familiar with networking and IP concepts. The gateway has to be integrated into the internal company network. The gateway setup therefore has to comply with the configuration of the internal networking. This description is intended to allow a network administrator not yet familiar with the Checkpoint FW-1/VPN-1 NGX Mobile VPN to configure a VPN with UMTS/GPRS usage.
2.1 Initial setup

In order to use the Checkpoint FW-1/VPN-1 NGX, the following components need to be set up:

· Enforcement point (firewall/gateway)

· Management Service (Can be installed on the gateway for a single firewall system)

· GUI-client Checkpoint SmartDashboard on a separate Windows PC

Thus, you need to install the management service and the GUI-client first before configuring the Firewall/VPN gateway. 
The Checkpoint FW-1/VPN-1 is a complex security system available for several hardware platforms and operating systems. To describe the complete installation and initial configuration for even one combination would exceed the boundaries of this document.

What is described here is the setup of a remote access VPN for a given installation reflecting the structure of the Reference Test Centre.
2.2 Needed Network Objects
The following network objects are needed for later steps and should be defined first.
·  “net-192.168.2.0_24”: Network object representing one of the networks to be accessible via remote access:

· Enter network address and mask of the networks the VPN users need to access.
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· “VPN-RTC-Access”: Group object containing all networks to be accessible via remote access:

· Add the networks here that will be accessed from the VPN users; here this will be “net-192.168.2.0_24”.

· Add other networks as needed.
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· “OfficeModeIP-Pool”: Network object defining the IP network used as internal address for SecureClient VPN clients:

· Enter network address and mask of the IP pool needed for the internal interface of the VPN Clients if SecureClient is used (Office Mode).
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· “RTCEX01”: DNS server used for VPN clients

· Enter IP address
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· “fwref01”: Firewall object, which needs to be extended in the following aspects:

· General Properties: If not already done, check the products “VPN” and, if SecureClient shall be used, “SecureClient Policy Server”. Make sure the needed licenses are entered in the license management.

· Topology: Below VPN Domain, check “Manually defined” and select the group object “VPN-RTC-Access” to define the VPN domain.

· VPN>VPN Advanced: If “Support NAT traversal” below “NAT traversal (Industry standard)” is checked, SecureClient will use the standard mechanism for NAT traversal on UDP-port 4500 instead of the proprietary port 2746 that Checkpoint uses by default. If this box is checked, the port in the “Remote Access” screen will be ignored.

· Remote Access: Make sure below “NAT traversal”, “Support NAT traversal mechanism” is checked.

· Remote Access>Office Mode: Select “Allow Office Mode to all users”. Check “Using one of the following methods”, select “Manual” and select the “OfficeModeIP-Pool” object from the list. Click “Optional Parameters” and select the DNS server “RTCEX01” from the object list. Optionally enter a domain name. Click “OK”.

· Authentication: Below “Enabled Authentication Schemes”, select at least “Checkpoint Password”. Below “Policy Server”, select “All users” or a group of users available on the firewall.
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2.3 Remote Access Users

In the menu “Manage”, click “Users and Administrators…”. Click “New>User group…” to generate a new user group. This group will later contain the remote access users and can be used in firewall rules to restrict access.
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In the menu “Manage”, click “Users and Administrators…”. Click “New>Template…” to generate a user template. In the “General” tab, enter a name for the template. In “Groups”, click the previously defined user group and click “Add>”. 
[image: image8.png]Users and Adnministatos:

Show: [A1

fonove | ga

Cose | actions. Hep




 [image: image9.png]User Template Propert

Location

Avallble Groups

Genonl | Pasond G

| e
ws | duenicoion

Belongs to Groups

Name
SecuRemtellsers
VPN-Tests2006

<Bemove

Name




 [image: image10.png][=i

mm [ w [ Eew
Gered | Pasond | Giows | Authenicaion

Templat name:  [VPH.test template]

= o




 

In “Authentication”, select “Checkpoint Password” as “Authentication Scheme”. In Encryption, check “IKE”. Click “Edit…” to open the Phase 2 Properties dialog. Make sure that “Public Key” is checked.

The Encryption parameters itself are set up globally and need not be set up here. These are set up in the global properties dialog.
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Close the dialogs by clicking “OK” to return to the “Users and Administrators” dialog. Create new users by selecting “New…>User by template>VPN.test.template”. Enter the user’s login name in the “General” tab and the user’s password in the “Authentication” tab. Click “OK” to close the dialogs.
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2.4 Authentication and VPN parameters
In the menu “Policy”, click “Global Properties…”. In the tree, click “Remote Access”. Make sure “Update topology …” is checked. Select “Upon VPN-1 SecuRemote/SecureClient start up”.
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In the entry “VPN-Basic” below “Remote Access”, make sure “Pre-Shared Secret” and “Support Legacy Authentication for SC” are checked.

In the entry “VPN-Advanced” below “Remote Access”, select “Dropped” when disconnected, to avoid confidential data entering the Internet unencrypted.

In the entry “VPN-IKE (Phase 1)” below “Remote Access”, select the appropriate encryption algorithm, data integrity and Diffie-Hellman group for the control connection. We recommend AES-256, SHA1 and DH-Group 2.

In the entry “VPN-IPSEC (Phase 2)” below “Remote Access”, select the appropriate encryption parameters for the data transfer. We recommend at least 3DES or AES encryption and SHA-1 as hash function. Check “Enforce Encryption Algorithm and Data Integrity on all users”.
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2.5 Changes to the rule base

The following setup is based on a “traditional” rule base, which contains encryption actions additionally to standard firewall actions like “drop” or “accept”. The “traditional” policy can be converted into “simplified” by using the menu “Policy>Convert to>Simplified VPN…”.
To start a new rule base in “traditional” mode, open the Global Properties from the menu “Policy>Global Properties”. Select the tree entry “VPN” and select either “Traditional mode to all new Security Policies” or “Traditional or Simplified mode per new Security Policy”.

The new policy can then be created from the menu “File>New”. Select Security and Address Translation and select “Traditional mode” to follow this example configuration. If SecureClient is being used, make sure “Desktop Security” is also checked.
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Further, in the Global Properties, “Firewall Implied Rules”, make sure that “Accept Remote Access control connections” is checked.

Create a new rule near the top of the rule base, so that the VPN rules are parsed before the stealth rule which denies access to the firewall itself. Optionally name the rule. Right-click the “Source” field in the rule and select “Add user access…”. Select the previously defined user group to allow access for this group. In the “Destination” field, add the protected networks, the remote access users need access to. Optionally, restrict the access to the desired services in the “Service” field. Right-click the “Action” field to select the action “Client Encrypt”. This action is only available in “traditional” mode. Right-click the action field again to select “Edit properties…”. Make sure, “intersect with user database” is selected for “Source” and “Destination”. Do not check “Apply Rule Only if Desktop Configuration Options are Verified”. Optionally, log the actions, add any comments. Select the gateway this rule is installed on by dragging the firewall object into the “Install On” field.
In the same way, define a second rule below the just defined one. Define it exactly as the first, but as destination, state the firewall object and the service should be “tunnel_test”. This will allow the client to test the connectivity to the VPN gateway.
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· Save and install your policy.
2.6 Using the SecuRemote, Availability of Split Tunnelling
Split Tunnelling is the standard for SecuRemote users and cannot be switched off because the SecuRemote VPN client does not have any personal firewall features. 

Further, SecuRemote does not have an internal virtual network interface and it is therefore not possible to use a predefined pool. This implies that the external IP address of the VPN client will be used as source address for encrypted packets. So, within the corporate, it will be difficult to determine where the data packets come from. Routing within the corporate must be set up so that the default gateway points to the firewall responsible for the remote access.

2.7 Using the SecureClient, Configuration of Split Tunnelling
If the SecureClient is used, some additional features above simple encryption are possible. Be aware that the client must be licensed.
· The SecureClient allows using a Desktop Security Policy. This allows configuring the unencrypted access to and from the internet for VPN users.
· SecureClient can be used in “Office Mode”, which allows defining an internal network interface on the client with an IP address from a defined pool of IP addresses.

· When Office mode is active, SecureClient can work in Hub mode, which tunnels all client traffic through the VPN tunnel. In this case, the corporate firewall will forward the traffic according to the main rule base. This allows the application of the advanced capabilities at the central location, like content scanning and scanning of higher network layers.

To configure Split Tunnelling for SecureClients, open the SmartDashboard and switch to the tab “Desktop Security”.
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The “Inbound Rules” define the data packets coming from the Internet into the client. To protect the client computer, all incoming connections are blocked. This rule does not affect answers coming back from the internet due to the stateful inspection, which keeps a log of connections initiated on the client and allows the answers back in.

The “Outbound Rules” define the access of the client computer to the Internet. When Split Tunnelling is desired, the outbound rule base must “Accept” traffic from the client PC to any destination. In case of Split Tunnelling disabled, the rule must “Block” all traffic not intended for the secured networks.
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Rule 3 in the above example is needed to support the keep-alive packets. For keep-alive packets to be active, the corresponding rule in the Security rule base and an entry in the global properties is needed. See also chapter ‎2.9.

After changing the policy, install the policy including the Desktop policy. When the client starts the VPN connection next time, the policy is updated.

2.8 Virtual Network Interface

As configured in chapter ‎2.2, the SecureClient uses a virtual network interface which obtains an IP address from a predefined pool. This increases the network security, since VPN clients will always use the well-defined IP pool for access of protected servers. This allows Intrusion Detection systems to identify the origin of these requests. Further, IP routing within the corporate network is simplified.
2.9 Advanced Settings

Since we are doing IPSec over an address translation we need to enable IPSec encapsulation over UDP. This is configured in the firewall object.

In the object tree, open the firewall object by either double-clicking it or right-click or selecting “Edit…” Select the tree entry “Remote Access” to display the remote access settings. Below NAT traversal, check “Support for NAT traversal mechanism” to enable IPSec encapsulation.
By default, the “Allocated port” is “VPN1_IPSEC_encapsulation”, which is UDP/2746. To use the standard conforming NAT-Traversal mechanism, additionally select “Support NAT traversal” in the “VPN>VPN Advanced” tree entry. See also chapter ‎2.2.
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There is a keep-alive setup in the Global Properties. To enable the keep-alive packets, open the Global Properties window by selecting the menu item “Policy>Global Properties”. Select the tree item “Remote Access”. Below “Additional Properties”, check “Enable Back Connections”. Now the keep-alive interval can be set. The default is 20 seconds.
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2.10 Data Compression

Data compression using Deflate compression algorithm is available for SecureClient and can be enabled in the Global Properties menu. Enabling data compression might speed up the data transmission rate of VPN users and may reduce the total volume transferred. On the other hand, the compression increases processor load and the time to compress the data increases the latency of the data packets. Further, the saving depends highly on the data format transferred. E.g. MP3 encoded music or ZIP archives are not compressed.  In the tests reported in the main body of this document (Chapter 7), VPN-based compression was not found to provide significant benefit beyond that provided by network-based optimisation and application-based compression (Microsoft Outlook).
To enable or disable compression, open the Global Properties by selecting the menu “Policy>Global Properties…” In the tree, expand the “Remote Access” item and select “VPN-Basic”. Below “IP compression”, check “Enable IP compression for SecureClient” to enable compression or uncheck it otherwise. 
Be aware that compression will not be active for SecuRemote.
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3 Logging
The Checkpoint Firewall features a separate logging GUI, SmartView Tracker, which connects to a logging server. This logging server is usually set up where the management service resides. The SmartView Tracker can be started either from the Windows start menu or, if the SmartDashboard configuration tool is already running, via the menu “Window>SmartView Tracker”.
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Additionally to the firewall log in the “Log” tab, the active connections can be viewed in the “Active” tab and the audit information is listed in the “Audit” tab.

The SmartView Tracker is highly configurable and allows setting up individual queries and filters. When right-clicking the column title, it is possible to define a filter or hide the column completely. The so defined query can be saved for later use by selecting the menu “Query>Save as”. The predefined and custom queries can be displayed in a tree view when selecting the menu “View>Query Tree”.
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Double-clicking the entry line will open a dialog box showing the information on this log entry alone. By right-clicking the entry line, an automatic query can be generated which will filter all entries with e.g. the same source, destination or user.
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Further the use of the network tools ping, whois and nslookup for the destination is possible by right-clicking a log entry.
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